DioError (DioError [DioErrorType.DEFAULT]: RangeError (index): Invalid value: Only valid value is 0: 1#0 List.[] (dart:core-patch/growable_array.dart:177:60)

出现这种错误,两种原因 1. 缺少请求协议信息。2.可能因为各种原因请求的URL地址不完整。